Search found 116 matches

Go to advanced search

by blorenz
24 May 2024, 08:15
Forum: Helpdesk
Topic: Problem installing polymake with Jupyter
Replies: 1
Views: 697

Re: Problem installing polymake with Jupyter

The files for the jupyter interface were removed from the polymake package on fedora since it is available as a separate package: python3-jupyter-polymake
Please try installing this package instead of using the jupyter script.

Best
Benjamin
by blorenz
25 Mar 2024, 12:35
Forum: Helpdesk
Topic: [Solved] Unexpected asymmetrical regular subdivision obtained from a symmetrical input
Replies: 2
Views: 4970

Re: Unexpected asymmetrical regular subdivision obtained from a symmetrical input

Please try homogenizing your points: polytope > $M = new Matrix<Rational>([[2,2,0,0,0,0],[0,2,2,0,0,0],[0,0,2,2,0,0],[0,0,0,2,2,0],[0,0,0,0,2,2],[2,0,0,0,0,2],[2,0,2,0,0,0],[0,2,0,2,0,0],[0,0,2,0,2,0],[0,0,0,2,0,2],[2,0,0,0,2,0],[0,2,0,0,0,2],[2,0,0,2,0,0],[0,2,0,0,2,0],[0,0,2,0,0,2],[3/2,1/2,1/2,1/...
by blorenz
13 Mar 2024, 13:46
Forum: Helpdesk
Topic: Creating order polytopes from face lattices
Replies: 2
Views: 8809

Re: Creating order polytopes from face lattices

There is an issue in our code that order_polytope only accepts a specific variant of the lattice type, you can convert it like this to work around that bug: polytope > $polygon = n_gon(3); polytope > $lattice = $polygon->HASSE_DIAGRAM; polytope > $l = new Lattice<BasicDecoration>(DECORATION=>$lattic...
by blorenz
12 Mar 2024, 18:15
Forum: Helpdesk
Topic: Output format of FACETS
Replies: 3
Views: 7796

Re: Output format of FACETS

poly2lp requires an LP for the objective function, either as a subobject or as a second argument, e.g.: polytope > $c = cube(3); polytope > $lp = $c->LP(LINEAR_OBJECTIVE=>[0,1,1,1]); polytope > poly2lp($c, $lp); MINIMIZE obj: +1 x1 +1 x2 +1 x3 Subject To ie0: +1 x1 >= -1 ie1: -1 x1 >= -1 ie2: +1 x2...
by blorenz
12 Mar 2024, 16:16
Forum: Helpdesk
Topic: Output format of FACETS
Replies: 3
Views: 7796

Re: Output format of FACETS

The (dim) (key value) ... style is for sparse vectors / matrices where the first entry is the length and each following pair is index and value. You can force the default output with dense : polytope > print dense($c->FACETS); 0 1 0 0 1 -1 0 0 0 0 1 0 1 0 -1 0 0 0 0 1 1 0 0 -1 Regarding .lp output y...
by blorenz
13 Nov 2023, 23:42
Forum: Helpdesk
Topic: Test failure with v4.11
Replies: 2
Views: 10444

Re: Test failure with v4.11

I guess that is the same issue as reported in this topic.
This patch should fix it: https://polymake.org/downloads/barycentric_subdiv.patch

Benjamin
by blorenz
07 Nov 2023, 16:57
Forum: Installing polymake
Topic: Undefined behavior in topaz app
Replies: 2
Views: 10578

Re: Undefined behavior in topaz app

Thanks for the report, I have fixed this for our master branch. I am slightly surprised that this did not trigger the sanitizer build in our CI, but I will check if we can add _GLIBCXX_ASSERTIONS to one of the builds. Benjamin - if (description.back() != '\n') + if (description.empty() || descriptio...
by blorenz
27 May 2023, 13:12
Forum: General Discussion
Topic: How to define Newton polytopes of a list of polynomials and compute the vertices, rays?
Replies: 3
Views: 17269

Re: How to define Newton polytopes of a list of polynomials and compute the vertices, rays?

I think your polynomial is not parsed as expected, it might be using the Singular-inspired short form where \(3x5\) would be turned into \(3*x^5\), and \(x11\) will end up as \(x^{11}\). So to make sure this is parsed as variables please add an underscore: polytope > $str = "(x11*x21 + x11*x22 ...
by blorenz
05 Feb 2023, 11:30
Forum: Helpdesk
Topic: mptopcom build failed
Replies: 1
Views: 10160

Re: mptopcom build failed

This error g++: fatal error: Killed signal terminated program cc1plus is quite often an indication that your computer ran out of memory and the operating system killed the process. Have you tried running the build process with less jobs, i.e. `ninja -C build/Opt -j1`. I would recommend at most one p...
by blorenz
16 Jan 2023, 14:25
Forum: Helpdesk
Topic: jreality doesn't start
Replies: 3
Views: 11152

Re: jreality doesn't start

You can set the default to jreality with prefer "jreality"; This will be stored in the polymake configuration ( ~/.polymake/settings ) and persist across sessions, until you use reset_preference to restore the default behaviour, see https://polymake.org/doku.php/user_guide/howto/shell_cust...

Go to advanced search