Problem installing polymake with Jupyter

Questions and problems about using polymake go here.
Posts: 1
Joined: 27 May 2022, 04:23

Problem installing polymake with Jupyter

Postby luis.torres » 24 May 2024, 00:14


I am using polymake 4.10 on a machine with Fedora 38. I installed both polymake and jupyter-notebook with the DNF package manager. Then I have tried to follow the installation instructions given in But when I run the command polymake --script jupyter I get the following error message:

Code: Select all

polymake: WARNING: created private directory /home/luismiguel/.polymake This function installs the jupyter-polymake kernel and the python libpolymake interface JuPyMake for the current user (into ~/.local). You need to have a running version of the jupyter notebook for python3 installed. Are you sure you want to continue with the installation? [y/N] y polymake: ERROR: Installation failed, please check the output: cp: cannot stat '/usr/share/polymake/resources/jupyter-polymake': No such file or directory
Could you please tell me what could be the problem here?

- Luis

Posts: 140
Joined: 10 Jan 2011, 17:21

Re: Problem installing polymake with Jupyter

Postby blorenz » 24 May 2024, 08:15

The files for the jupyter interface were removed from the polymake package on fedora since it is available as a separate package: python3-jupyter-polymake
Please try installing this package instead of using the jupyter script.


Return to “Helpdesk”