mptopcom build failed

Questions and problems about using polymake go here.
Posts: 30
Joined: 13 Aug 2015, 20:41

mptopcom build failed

Postby beew » 04 Feb 2023, 23:43


I tried to build mptopcom and it failed with

$ ninja -C build/Opt install

Code: Select all

ninja: Entering directory `build/Opt' [1/1] GENERATE /home/bernard/src/mptopcom-1.3/build/ [101/128] COMPILE /home/bernard/src/mptopcom-1.3/build/Opt/lib-src/ComputeTriangs.o FAILED: /home/bernard/src/mptopcom-1.3/build/Opt/lib-src/ComputeTriangs.o g++ -DPACKAGE_NAME=\"TOPCOM\" -DPACKAGE_TARNAME=\"topcom\" -DPACKAGE_VERSION=\"0.17.10\" -DPACKAGE_STRING=\"TOPCOM\ 0.17.10\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"topcom\" -DVERSION=\"0.17.10\" -DGMPRATIONAL -c -o /home/bernard/src/mptopcom-1.3/build/Opt/lib-src/ComputeTriangs.o -MMD -MT /home/bernard/src/mptopcom-1.3/build/Opt/lib-src/ComputeTriangs.o -MF /home/bernard/src/mptopcom-1.3/build/Opt/lib-src/ComputeTriangs.o.d -fPIC -pipe -std=c++17 -march=native -ftemplate-depth-200 -fno-strict-aliasing -Wno-parentheses -fwrapv -fopenmp -DHAS_SOPLEX -DNDEBUG -O3 -I/usr/local/include -I/home/bernard/src/mptopcom-1.3/lib-src -I/home/bernard/src/mptopcom-1.3/lib-src-reg -I/home/bernard/src/mptopcom-1.3/wrap-gmp-gmpxx -I/home/bernard/src/mptopcom-1.3/lib-src-ReverseSearch -DPOLYMAKE_VERSION=409 -fPIC -pipe -std=c++14 -march=native -ftemplate-depth-200 -fno-strict-aliasing -fopenmp -Wshadow -Wlogical-op -Wconversion -Wzero-as-null-pointer-constant -Wno-parentheses -Wno-error=unused-function -Wno-stringop-overflow -Wno-array-bounds -Wno-maybe-uninitialized -Wno-free-nonheap-object -DPOLYMAKE_WITH_FLINT -O3 -DPOLYMAKE_DEBUG=0 -std=c++17 -I/usr/local/include -I/usr/local/include/polymake/external -I/usr/include/cdd /home/bernard/src/mptopcom-1.3/lib-src/ {standard input}: Assembler messages: {standard input}:518788: Warning: end of file not at end of a line; newline inserted {standard input}:519239: Error: expected comma after name `_ZN13ReverseSearchILb1ELb1E11FlipDataSymI14RegularCheckerI30AugmentedPointConfigurationSymISt17integral_constantIbLb0EES4_S3_IbLb1EEES5_ES6_ES6_9TreeGraphIS8_S6_EE19auto_reverse_sear' in .size directive g++: fatal error: Killed signal terminated program cc1plus compilation terminated. [104/128] COMPILE /home/bernard/src/mptopcom-1.3/build/Opt/src-mp/mptopcom.o ninja: build stopped: subcommand failed.

The outputs for configure

Code: Select all

./configure --prefix=$HOME/mptopcom checking polymake installation ... ok (4.9) checking C++ compiler ... ok (g++ is GCC 11.3.0) checking C++ library ... ok (GNU libstdc++ 20220421, C++ 201703) checking mpi installation ... ok (Open MPI 4.1.2 (Language: C++)) determining architecture ... ok (x86_64) determining compiler flags ... ok CFLAGS= -march=native CXXFLAGS= -std=c++17 -march=native -ftemplate-depth-200 -fno-strict-aliasing -Wno-parentheses -fwrapv -fopenmp checking whether polymake can solve lp ... ok (soplex detected). checking cdd installation ... ok (0.94m @ system)
OS is Ubuntu 22.04 Thanks.

Posts: 140
Joined: 10 Jan 2011, 17:21

Re: mptopcom build failed

Postby blorenz » 05 Feb 2023, 11:30

This error

Code: Select all

g++: fatal error: Killed signal terminated program cc1plus
is quite often an indication that your computer ran out of memory and the operating system killed the process. Have you tried running the build process with less jobs, i.e. `ninja -C build/Opt -j1`. I would recommend at most one process per 2GB of memory and not more than the number of cpu cores / threads available. (Unfortunately ninja defaults to #cpus+2, which might work well for C projects but is not ideal for C++ projects with many templates)


Return to “Helpdesk”