Can't locate loadable object for module Polymake::Ext in @INC

Discussions on installation issues go here.
grkj
Posts: 2
Joined: 01 Jun 2024, 01:57

Can't locate loadable object for module Polymake::Ext in @INC

Postby grkj » 01 Jun 2024, 02:15

I know there is similar questions, but i can't understand their solutions, or if they are applicable for me.

My machine i am using macOS Sonoma 14.1 (23B74) on m1.
I am trying to install Polymake and use it in Jupyter Notebook.
I made all steps from https://polymake.org/doku.php/install/macos till "Download polymake" section, cause i want to install Polymake via homebrew (as i understood it is more lighter way to make them work with Jupyter later). When i start installing by

Code: Select all

brew install polymake
I get

Code: Select all

==> Downloading https://formulae.brew.sh/api/formula.jws.json #=#=- # # ==> Downloading https://formulae.brew.sh/api/cask.jws.json ==> Fetching apaffenholz/polymake/polymake ==> Downloading https://github.com/apaffenholz/homebrew-polymake/releases/download/polymake-4.11/polymake-4.11.sonoma.bottle.tar.gz ==> Downloading from https://objects.githubusercontent.com/github-production-release-asset-2e65be/267949068/b0bdd3f0-4faf-46b8-ab93-f845e7e77734?X-Am ############################################################################################################################################## 100.0% ==> Installing polymake from apaffenholz/polymake ==> Pouring polymake-4.11.sonoma.bottle.tar.gz ==> Caveats Note: This version comes without support for SVG export. If you had any other version of polymake installed on your Mac (both previous versions installed via Homebrew or any other installations) you must start polymake once with "polymake --reconfigure" to remove the configuration of SVG support from your local polymake setup. Afterwards you can use "polymake" as usual. ==> Summary 🍺 /usr/local/Cellar/polymake/4.11: 2,464 files, 174.2MB ==> Running `brew cleanup polymake`... Disable this behaviour by setting HOMEBREW_NO_INSTALL_CLEANUP. Hide these hints with HOMEBREW_NO_ENV_HINTS (see `man brew`).
And then i type

Code: Select all

polymake --reconfigure Can't locate loadable object for module Polymake::Ext in @INC (@INC contains: /usr/local/Cellar/polymake/4.11/share/polymake/perllib /usr/local/Cellar/polymake/4.11/lib/polymake/perlx /usr/local/Cellar/polymake/4.11/libexec/perl5/lib/perl5/darwin-thread-multi-2level /usr/local/Cellar/polymake/4.11/libexec/perl5/lib/perl5 /usr/local/opt/perl/lib/perl5/site_perl/5.38/darwin-thread-multi-2level /usr/local/opt/perl/lib/perl5/site_perl/5.38 /usr/local/opt/perl/lib/perl5/5.38/darwin-thread-multi-2level /usr/local/opt/perl/lib/perl5/5.38 /usr/local/lib/perl5/site_perl/5.38) at /usr/local/Cellar/polymake/4.11/share/polymake/perllib/Polymake/Namespaces.pm line 18. Compilation failed in require at /usr/local/Cellar/polymake/4.11/share/polymake/perllib/Polymake/Namespaces.pm line 18. BEGIN failed--compilation aborted at /usr/local/Cellar/polymake/4.11/share/polymake/perllib/Polymake/Namespaces.pm line 18. Compilation failed in require at /usr/local/Cellar/polymake/4.11/share/polymake/perllib/Polymake.pm line 29. BEGIN failed--compilation aborted at /usr/local/Cellar/polymake/4.11/share/polymake/perllib/Polymake.pm line 29. Compilation failed in require at /usr/local/Cellar/polymake/4.11/libexec/perl5/bin/polymake line 156. BEGIN failed--compilation aborted at /usr/local/Cellar/polymake/4.11/libexec/perl5/bin/polymake line 156.
Can someone say what is wrong and what can i do with it?

Thanks for your time, M

Return to “Installing polymake”