Installing on a MacBook Pro OS 13.1

Discussions on installation issues go here.
bgkagy3
Posts: 2
Joined: 10 Jan 2023, 01:01

Installing on a MacBook Pro OS 13.1

Postby bgkagy3 » 10 Jan 2023, 01:11

Hello,
I m trying to follow the download instructions but I am having a lot of trouble. I am not that familiar with Mac OS so that may be the issue.

I downloaded the 11.3 bundle (This was the most recent bundle I could find but this itself may be the issue)
and I moved it to applications and got the program to run. However when I click on the program to run it says that “polymake.run” can’t be opened because (null) is not allowed to open documents in Terminal. I tried giving polymake full disk access but that didn't work either.

Let me know if you can what I should be doing. I'm guessing I need to download a version for 13.1 instead but I can't seem to find that on the polymake website.

paffenholz
Developer
Posts: 206
Joined: 24 Dec 2010, 13:47

Re: Installing on a MacBook Pro OS 13.1

Postby paffenholz » 11 Jan 2023, 23:41

It may help do remove the quarantine bit for polymake with

Code: Select all

sudo xattr -r -d com.apple.quarantine /Applications/polymake.app/
but I am pretty sure that the bundle for 11.3 will not work on 13.1 due to different perl versions and some other changes in the system. It certainly won't if you have a Mac with an arm processor.

11.3 is indeed the newest bundle available. I have plans to produce one for 12 and 13, and new binaries for homebrew, but I can't say when this will actually happen. Until then, your only option is probably to compile from the sources. I haven't tested, by I expect that the installation instructions on our page also work on 13.1.

bgkagy3
Posts: 2
Joined: 10 Jan 2023, 01:01

Re: Installing on a MacBook Pro OS 13.1

Postby bgkagy3 » 13 Jan 2023, 05:34

Yeah i got it to download with the instructions to compile from the sources.

I got a weird error where it says "Loading applications now...Can't locate object method "new" via package "Term::ReadLine::Gnu" at /usr/local/share/polymake/perllib/Polymake/Core/Shell.pm line 54." when i try to run polymake

every new time i open the terminal i have to run

\curl -L https://install.perlbrew.pl | bash
echo "export PERL5LIB=$HOME/perl5/lib/perl5:$HOME/perl5${PERL5LIB+:$PERL5LIB}" >> $HOME/.zshrc
echo "source ~/perl5/perlbrew/etc/bashrc" >> $HOME/.zshrc
echo 'export ARCHFLAGS="-arch x86_64"' >> $HOME/.zshrc
source $HOME/.zshrc
cpanm ZEFRAM/Module-Runtime-0.013.tar.gz —force

which i got from the source download instructions. I don't really know whats thats doing or what the issue is but it does seem to fix the issue for that terminal session.


Return to “Installing polymake”