Running into error with 3.2 installation

Questions and problems about using polymake go here.

Moderator: Moderators

User avatar
gawrilow
Main Author
Posts: 330
Joined: 25 Dec 2010, 17:40

Re: Running into error with 3.2 installation

Postby gawrilow » 31 Jan 2018, 15:23

... it installs 3.0 with ppl.
with old one, as Ben pointed out.

UserCplex
Posts: 22
Joined: 11 Jan 2018, 13:37

Re: Running into error with 3.2 installation

Postby UserCplex » 02 Mar 2018, 10:52

Just a short information regarding ppl:
Ubuntu 16.04 provides ppl version 1.1 while polymake 3.2 needs version at least 1.2.
So it does make sense that polymake 3.0 can work with the installed ppl but polymake 3.2 cannot.
Hello blorenz

Could you let me know how on ubuntu I can install ppl version 1.2? I want to upgrade to polymake 3.2 on ubuntu 16.04 LTS.

Thank you.

blorenz
Developer
Posts: 109
Joined: 10 Jan 2011, 17:21

Re: Running into error with 3.2 installation

Postby blorenz » 02 Mar 2018, 11:10

Since ppl 1.2 is not available as a package for Ubuntu 16.04 you need to download and install it manually, it is available here.

Something like the following should work for the installation, please check the INSTALL and README.configure files in the ppl package for more information.

Code: Select all

./configure --enable-interfaces=cxx --enable-static=no --enable-documentation=no --prefix=/opt/ppl12 make -j4 make install
Then you need to configure polymake to use this ppl installation with

Code: Select all

./configure --with-ppl=/opt/ppl12
Best
Benjamin

User avatar
gawrilow
Main Author
Posts: 330
Joined: 25 Dec 2010, 17:40

Re: Running into error with 3.2 installation

Postby gawrilow » 07 Mar 2018, 09:29

Another option is to run polymake docker image, it comes equipped with ppl 1.2 (and many other things).


Return to “Helpdesk”

cron