Running into error with 3.2 installation

Questions and problems about using polymake go here.

Moderator: Moderators

Jteve
Posts: 7
Joined: 16 Jan 2018, 04:35

Running into error with 3.2 installation

Postby Jteve » 31 Jan 2018, 07:49

Hello,

On the new version, I am running into trouble at the ./configure (with default options) and subsequent steps.

Code: Select all

user@user-Inspiron-3268:~/Downloads/polymake-3.2$ ./configure checking C++ compiler ... ok (g++ is GCC 5.4.0) checking C++ library ... ok (GNU libstdc++ 20160609, C++ 201402) determining architecture ... ok (x86_64) determining compiler flags ... ok CFLAGS= -march=native CXXFLAGS= -std=c++14 -march=native -ftemplate-depth-200 -fno-strict-aliasing -Wno-parentheses -fwrapv -fopenmp checking gmp installation ... ok checking mpfr installation ... ok checking boost installation ... ok checking libxml2 installation ... Could not find configuration program xml2-config for library libxml2. Probably you need to install development package for it; usually it is called libxml2-devel or similarly. If the library is installed at a non-standard location, please specify it in option --with-libxml2 ---- user@user-Inspiron-3268:~/Downloads/polymake-3.2$ make ninja -C build/Opt all make: ninja: Command not found Makefile:34: recipe for target 'all' failed make: *** [all] Error 127 ---- user@user-Inspiron-3268:~/Downloads/polymake-3.2$ sudo make install [sudo] password for user: ninja -C build/Opt install make: ninja: Command not found Makefile:34: recipe for target 'install' failed make: *** [install] Error 127
I tried sudo apt-get install libxml2-dev as well as sudo apt-get install libxml2-devel

as suggested by the ./configure command, but neither of these packages seem to be installable.

Code: Select all

E: Unable to locate package libxml2-devel
Any help is appreciated.

User avatar
gawrilow
Main Author
Posts: 331
Joined: 25 Dec 2010, 17:40

Re: Running into error with 3.2 installation

Postby gawrilow » 31 Jan 2018, 09:56

Your system lacks at least two packages, the first one is ninja-build (visible thanks to the message "ninja: Command not found"), the second one is in fact the development package for libxml2. The suggested name is just a hint. On Ubuntu 16.04 this package is called libxml2-dev, other Linux distributions may use other names, but they should have libxml2 in the name. I bet libxslt1-dev and both perl wrappers, libxml-libxml-perl and libxml-libxslt-perl, are missing on your computer as well. If your system is indeed a Ubuntu, please check the full requested package list on https://polymake.org/doku.php/howto/ins ... and_ubuntu .

Jteve
Posts: 7
Joined: 16 Jan 2018, 04:35

Re: Running into error with 3.2 installation

Postby Jteve » 31 Jan 2018, 12:44

Hi gawrilow,

Based on your suggestion, I did install the packages, but have run into a few further issues now.

./configure gives the following output with certain failed operations:

Code: Select all

checking C++ compiler ... ok (g++ is GCC 5.4.0) checking C++ library ... ok (GNU libstdc++ 20160609, C++ 201402) determining architecture ... ok (x86_64) determining compiler flags ... ok CFLAGS= -march=native CXXFLAGS= -std=c++14 -march=native -ftemplate-depth-200 -fno-strict-aliasing -Wno-parentheses -fwrapv -fopenmp checking gmp installation ... ok checking mpfr installation ... ok checking boost installation ... ok checking libxml2 installation ... ok checking perl module XML::Writer ... ok checking perl module XML::LibXML ... ok checking perl module XML::LibXSLT ... ok checking perl module Term::ReadKey ... ok checking perl module Term::ReadLine ... ok checking shared perl library ... ok Configuring bundled extensions: bundled extension bliss ... ok bundled extension cdd ... ok (bundled) bundled extension java ... ok (JNI headers at /usr/lib/jvm/java-8-openjdk-amd64/include) bundled extension javaview ... failed bundled extension jreality ... ok (with bundled JOGL) bundled extension libnormaliz ... ok (bundled) bundled extension lrs ... ok (bundled) bundled extension nauty ... disabled because of conflict with other extension: bliss bundled extension ppl ... failed bundled extension singular ... failed bundled extension soplex ... failed bundled extension sympol ... ok (bundled) bundled extension atint ... ok * If you want to change the configuration of bundled extensions please see build/bundled.log and try configure --help. * Configuration successful. * You can run 'ninja -C build/Opt install' now to build and install polymake.
ppl and other algorithms seemed to have failed.

make proceeds as follows:

Code: Select all

ninja -C build/Opt all ninja: Entering directory `build/Opt' [1/1] GENERATE /home/user/Downloads/polymake-3.2/build/targets.ninja [873/938] BUILD /home/user/Downloads/polymake-3.2/build/Opt/jars/polymake_java.jar Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. [888/938] BUILD /home/user/Downloads/polymake-3.2/build/Opt/jars/polymake_jreality.jar Using Java version 1.8. Note: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details. Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. Note: /home/user/Downloads/polymake-3.2/bundled/jreality/external/jreality/src-tool/de/jreality/toolsystem/virtual/VirtualExtractPositive.java uses or overrides a deprecated API. Note: Recompile with -Xlint:deprecation for details. Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. Note: /home/user/Downloads/polymake-3.2/bundled/jreality/external/jreality/src-backends-share/de/jreality/backends/label/LabelUtility.java uses unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. warning: [options] bootstrap class path not set in conjunction with -source 1.6 Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. 1 warning Note: /home/user/Downloads/polymake-3.2/bundled/jreality/external/jreality/src-proxies/de/jreality/scene/proxy/smrj/SMRJMirrorFactory.java uses unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. Note: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details. Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. Note: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details. Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. Note: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details. Note: /home/user/Downloads/polymake-3.2/bundled/jreality/external/jreality/src-ui/de/jreality/geometry/AbstractGeometryFactoryCustomizer.java uses unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. Note: Some input files use or override a deprecated API. Note: Recompile with -Xlint:deprecation for details. Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details. [938/938] touch /home/user/Downloads/polymake-3.2/build/Opt/.apps.built
sudo make install proceeds thus:

Code: Select all

[sudo] password for user: ninja -C build/Opt install ninja: Entering directory `build/Opt' [6/6] INSTALL core system in mode Opt at /usr/local/share/polymake
Then, when I start polymake, I get the following:

Code: Select all

user@user-Inspiron-3268:~/Downloads/polymake-3.2$ polymake Welcome to polymake version 3.2 Copyright (c) 1997-2018 Ewgenij Gawrilow, Michael Joswig (TU Berlin) http://www.polymake.org This is free software licensed under GPL; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Loading applications now...polymake: ERROR: "/usr/local/share/polymake/apps/common/perllib/PolyDB/DatabaseHelpers.pm", line 24: Can't locate JSON.pm in @INC (you may need to install the JSON module) (@INC contains: Polymake::Core::Application=ARRAY(0x31b70b0) /usr/local/share/polymake/perllib /usr/local/lib/polymake/perlx/5.22.1/x86_64-linux-gnu-thread-multi /usr/local/lib/polymake/perlx/5.22.1 /usr/local/lib/polymake/perlx /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .)
Prior to this install, I had installed polymake under the "debian/ubuntu" distribution.

Code: Select all

sudo apt-get install polymake
But that does not seem to have 3.2 yet and has 3.0 still. With the previous (3.0), with typing polymake, I did not encounter the errors I am obtaining now.

Thank you.

User avatar
gawrilow
Main Author
Posts: 331
Joined: 25 Dec 2010, 17:40

Re: Running into error with 3.2 installation

Postby gawrilow » 31 Jan 2018, 12:58

ppl, Singular, and soplex interfaces are optional for polymake, therefore the configuration process reported a success. On the page https://polymake.org/doku.php/external_software you'll find an overview of all optional interfaces together with links to the sites where you can download and install the missing third-party software , in case you really need them.

The JSON module is needed if you are going to interact with the polymake database, cf. https://polymake.org/doku.php/data . Unfortunately, we forgot to list the perl module on the installation page. To unblock yourself, please install the package libjson-perl.

Jteve
Posts: 7
Joined: 16 Jan 2018, 04:35

Re: Running into error with 3.2 installation

Postby Jteve » 31 Jan 2018, 13:08

Yes, after installing that, running polymake gives no errors at startup.

Regarding ppl, in my earlier post on this forum, I experienced a problem instance of computing facets for a set of points for which ppl ran very quickly as compared to lrs.

See viewtopic.php?f=8&t=607

In the opening line of polymake, I do not see ppl but see lrs:

Code: Select all

Welcome to polymake version 3.2 Copyright (c) 1997-2018 Ewgenij Gawrilow, Michael Joswig (TU Berlin) http://www.polymake.org This is free software licensed under GPL; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Press F1 or enter 'help;' for basic instructions. Application polytope currently uses following third-party software packages: SVG, bliss, cdd, graphviz, jreality, libnormaliz, lrs, permlib, polyDB, sketch, sympol, threejs, tikz, tosimplex For more details: show_credits;
Is my failed installation of ppl in ./configure above the reason why ppl is not available?

User avatar
gawrilow
Main Author
Posts: 331
Joined: 25 Dec 2010, 17:40

Re: Running into error with 3.2 installation

Postby gawrilow » 31 Jan 2018, 13:13

Yes, surely. Please check the log file build/bundled.log for messages explaining the failure reasons. When you have fixed the problem, repeat the configure and ninja install steps.

Please be aware that the polymake configuration script does not try to install ppl for you, neither any other third-party software. It merely checks for their presence and usability, then it enables or disables corresponding interfaces.

Jteve
Posts: 7
Joined: 16 Jan 2018, 04:35

Re: Running into error with 3.2 installation

Postby Jteve » 31 Jan 2018, 13:37

Hi gawrilow,

Thanks for your help. I was able to uninstall 3.2 and am back with 3.0 where things were working better for me. When I have more time, I will install 3.2 and hopefully get it up and running.

User avatar
gawrilow
Main Author
Posts: 331
Joined: 25 Dec 2010, 17:40

Re: Running into error with 3.2 installation

Postby gawrilow » 31 Jan 2018, 14:36

Well, you can surely choose which version to use, just be aware that the relationship between polymake and third-party packages has been the same for ages. If polymake 3.0 can find a ppl installation on your system then 3.2 will find at as well, and vice versa. So there must be another problem with your setup, independent from the current polymake version.

Anyway, triggered by your posts we updated the required package lists for Ubuntu and some other Linux distributions, which is good on its own right. Thanks for your patience!

blorenz
Developer
Posts: 109
Joined: 10 Jan 2011, 17:21

Re: Running into error with 3.2 installation

Postby blorenz » 31 Jan 2018, 14:58

Just a short information regarding ppl:
Ubuntu 16.04 provides ppl version 1.1 while polymake 3.2 needs version at least 1.2.
So it does make sense that polymake 3.0 can work with the installed ppl but polymake 3.2 cannot.

Jteve
Posts: 7
Joined: 16 Jan 2018, 04:35

Re: Running into error with 3.2 installation

Postby Jteve » 31 Jan 2018, 15:19

Just for info:

After I uninstalled 3.2 and installed 3.0 (by following instruction https://polymake.org/doku.php/howto/install) by simply running "sudo apt-get install polymake", it installs 3.0 with ppl.


Return to “Helpdesk”

cron