Problem with visualization

Questions and problems about using polymake go here.

Moderator: Moderators

Posts: 2
Joined: 11 Aug 2017, 11:47

Problem with visualization

Postby ivanovic » 11 Aug 2017, 12:55

I tried to visualize 3D polytope with $p->VISUAL;
but I got a message in terminal ERROR: could not provide all required input properties at input line 1.
I typed by hand:

Code: Select all

$n=new Matrix<Rational>([[-3,1,0,0,0],[-3,0,1,0,0],[-3,0,0,1,0],[-3,0,0,0,1],[-9,1,1,0,0],[-9,0,1,1,0],[-9,0,0,1,1],[-27,1,1,1,0],[-27,0,1,1,1]]); $p=new Polytope<Rational>(INEQUALITIES=>$n, EQUATIONS=>[[-81,1,1,1,1]]); $p->VISUAL;
Each line is OK but VISUAL doesn't work. I tried other 3D examples and got the same message.
2D visualization is OK. My opinion is that something goes wrong with javaView. Please, help me, I was trying to solve this all days.

User avatar
Main Author
Posts: 216
Joined: 24 Dec 2010, 11:10

Re: Problem with visualization

Postby joswig » 11 Aug 2017, 15:14

You could try

Code: Select all

instead of your last command. If it works you could then use

Code: Select all

prefer "threejs";
to set that kind of visualization as your standard. That is, pure VISUAL would start threejs afterwards.

For being able to help you more, you should specify on which kind of operating system you are using which version of polymake.

Return to “Helpdesk”