Using jReality in Polymake

Questions and problems about using polymake go here.
Aryaman
Posts: 2
Joined: 24 Mar 2022, 18:25

Using jReality in Polymake

Postby Aryaman » 24 Mar 2022, 18:55

Hi!

I'm using Polymake 4.0 on Ubuntu 20.04 via WSL2 on a Windows 10 machine. It was installed via a package manager and not from source.

I'm interested in using the jReality viewer through polymake but have so far been unsuccessful in doing so. jReality is listed as a bundled extension and the page here https://polymake.org/doku.php/external_software tells us that nothing needs to be downloaded and installed separately but I still haven't been able to access it and if I try doing something like jreality(cube(3)->VISUAL); I get the error Undefined subroutine &polytope::jreality called.

My question is: how do I enable the use of jReality? Do I need to use it as an extension? If so, how is that done? Do I need to uninstall my current version and reinstall from source perhaps? Any answers in this direction would be of help!

This might be irrelevant, but I also followed the instructions here https://www3.math.tu-berlin.de/jreality ... orial.html

but I was unable to make anything run, perhaps owing to the fact that I have the wrong version of java.

User avatar
gawrilow
Main Author
Posts: 405
Joined: 25 Dec 2010, 17:40

Re: Using jReality in Polymake

Postby gawrilow » 25 Mar 2022, 10:57

Unfortunately, for various technical and legal reasons, Ubuntu packages of polymake do not contain the jReality interface. It's only available in the full source version. But it won't work under Windows either.
You'll have to use a Linux or Mac system.

Aryaman
Posts: 2
Joined: 24 Mar 2022, 18:25

Re: Using jReality in Polymake

Postby Aryaman » 25 Mar 2022, 14:39

That's unfortunate but it wasn't a pressing issue. Anyway, thanks for the prompt reply!


Return to “Helpdesk”