show_unconfigured shows error "Unrecognized character \x7F"

Discussions on installation issues go here.

Moderator: Moderators

mkoeppe
Posts: 17
Joined: 27 Jun 2016, 19:44

show_unconfigured shows error "Unrecognized character \x7F"

Postby mkoeppe » 08 Jul 2016, 00:03

We observed a strange error message from "show_unconfigured" in the Polymake installation made by our preliminary Sage package (https://trac.sagemath.org/ticket/20892):

Code: Select all

polymake: ERROR: "/home/scratch/dimpase/sage/sage/local/lib/polymake/lib/polytope.so", line 1: Unrecognized character \x7F; marked by <-- HERE after <-- HERE near column 1
see https://trac.sagemath.org/ticket/20892#comment:51

Everything else seems to work fine.

blorenz
Developer
Posts: 109
Joined: 10 Jan 2011, 17:21

Re: show_unconfigured shows error "Unrecognized character \x7F"

Postby blorenz » 14 Jul 2016, 16:39

This error seems to be caused by having no graph-comparison tool available, which is a somewhat unsupported configuration.
The bliss extension failed to configure and the minimal package doesnt contain nauty as fallback because of its license. This package is meant for maintainers that make sure the dependencies are met via the packaging system.

We will add a warning to the configuration script for this case in the upcoming 3.0r2 bugfix release. We will also try to make the error less cryptic and less fatal.

Benjamin

mkoeppe
Posts: 17
Joined: 27 Jun 2016, 19:44

Re: show_unconfigured shows error "Unrecognized character \x7F"

Postby mkoeppe » 15 Jul 2016, 12:44

Thanks Benjamin.

Regarding bliss, you may want to mention in the wiki that polymake depends on Debian's patches to bliss.
(https://trac.sagemath.org/ticket/20901).

I believe I have nauty installed (via a Sage package). How do I make sure that polymake finds it?

User avatar
gawrilow
Main Author
Posts: 332
Joined: 25 Dec 2010, 17:40

Re: show_unconfigured shows error "Unrecognized character \x7F"

Postby gawrilow » 15 Jul 2016, 13:17

Currently polymake does not have any provisions for finding the nauty package outside own source code. I'd suggest you use the complete source tarball of polymake instead of the "minimal" one; you can disable undesired extensions via configuration like this: --without-jreality.

dimpase
Posts: 2
Joined: 07 Jul 2016, 12:21

Re: show_unconfigured shows error "Unrecognized character \x7F"

Postby dimpase » 15 Jul 2016, 14:38

This thread about nauty is somewhat outdated. Just in case, nauty now has a GPL-compatible license (including few 3rd party-licensed files it contains).
(It took us (sagemath) some time to convince Brendan to drop the incompatible part...)

http://users.cecs.anu.edu.au/~bdm/nauty/COPYRIGHT.txt

blorenz
Developer
Posts: 109
Joined: 10 Jan 2011, 17:21

Re: show_unconfigured shows error "Unrecognized character \x7F"

Postby blorenz » 25 Jul 2016, 14:30

We have released 3.0r2 now and included a warning when having neither bliss or nauty active. Further, the minimal tarball now includes the nauty interface which allows using a custom nauty source directory, polymake will then build a static library out of it. (The interface currently does not support nauty binaries or shared libraries)
We have also clarified the installation documentation regarding the minimal tarball.


Return to “Installing polymake”

cron