Installing Polymake in Arch GNU/Linux, LibXSLT error.

Discussions on installation issues go here.

Moderator: Moderators

Criado
Posts: 2
Joined: 12 Jun 2016, 15:58

Installing Polymake in Arch GNU/Linux, LibXSLT error.

Postby Criado » 12 Jun 2016, 16:26

I had some problems running Polymake after a system update, so I tried to compile the latest version from the git repo. Now I have this error:

Code: Select all

checking perl module XML::LibXSLT ... LibXSLT.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)
Some system info:

Code: Select all

$ uname -a Linux PCG 4.6.2-1-ARCH #1 SMP PREEMPT Wed Jun 8 08:40:59 CEST 2016 x86_64 GNU/Linux $ perl --version This is perl 5, version 24, subversion 0 (v5.24.0) built for x86_64-linux-thread-multi $ cpan -D XML::LibXSLT Loading internal null logger. Install Log::Log4perl for logging messages Reading '/home/criado/.cpan/Metadata' Database was generated on Sun, 12 Jun 2016 12:53:46 GMT XML::LibXSLT ------------------------------------------------------------------------- (no description) S/SH/SHLOMIF/XML-LibXSLT-1.94.tar.gz /usr/lib/perl5/site_perl/XML/LibXSLT.pm Installed: 1.94 CPAN: 1.94 up to date Shlomi Fish (SHLOMIF) shlomif@shlomifish.org

User avatar
gawrilow
Main Author
Posts: 308
Joined: 25 Dec 2010, 17:40

Re: Installing Polymake in Arch GNU/Linux, LibXSLT error.

Postby gawrilow » 12 Jun 2016, 20:53

XML::LibXSLT contains so called perl extensions (XS) which are binary incompatible across versions. If your Linux distribution does not contain a suitable package (many distributions do, like openSuSE or Ubuntu), you should probably re-install it using CPAN recompile command. The same applies to all other modules "contaminated" with XS, in particular XML::LibXML, Term::ReadLine::GNU, and Term::ReadKey.

Criado
Posts: 2
Joined: 12 Jun 2016, 15:58

Re: Installing Polymake in Arch GNU/Linux, LibXSLT error.

Postby Criado » 13 Jun 2016, 16:10

That solved it. I downloaded the LibXSLT module and recompiled it for my system instead of the cpan packaged binary. My old polymake binary works now too. Curiously enough, I only needed to recompile XML-LibXSLT.

Thanks!


Return to “Installing polymake”

cron