Binary OS X 10.10 error

Discussions on installation issues go here.

Moderator: Moderators

cllista

Binary OS X 10.10 error

Postby cllista » 23 Oct 2015, 10:30

When I install prebuilded OS X 10.10 version and when I try to run it then appear an dyld loading error.

Loading applications now...dyld: Library not loaded: /Users/andreas/polymake/polybundle/polymake.app/Contents/Resources/lib/libSingular-4.0.2.dylib
Referenced from: /Applications/polymake.app/Contents/MacOS/../Resources//bin/Singular
Reason: image not found

I think that when "andreas" build it the path defined to dyld library has defined the absolute local path and no relative one.

I could create an soft link to workaround it with next commands, but it is not the best solution:
sudo mkdir -p /Users/andreas/polymake
sudo ln -s /Applications/ /Users/andreas/polymake/polybundle

paffenholz
Developer
Posts: 171
Joined: 24 Dec 2010, 13:47

Re: Binary OS X 10.10 error

Postby paffenholz » 30 Oct 2015, 17:35

I am sorry, seems we overlooked some library references when building the bundle.

Here is a way to properly fix the error in your bundle. In a Terminal you can issue the following commands:

Code: Select all

cd /Applications/polymake.app/Contents/Resources/bin chmod u+w Singular install_name_tool -change "/Users/andreas/polymake/polybundle/polymake.app/Contents/Resources/lib/libSingular-4.0.2.dylib" "@rpath/libSingular-4.0.2.dylib" Singular install_name_tool -change "/Users/andreas/polymake/polybundle/polymake.app/Contents/Resources/lib/libpolys-4.0.2.dylib" "@rpath/libpolys-4.0.2.dylib" Singular install_name_tool -change "/Users/andreas/polymake/polybundle/polymake.app/Contents/Resources/lib/libfactory-4.0.2.dylib" "@rpath/libfactory-4.0.2.dylib" Singular install_name_tool -change "/Users/andreas/polymake/polybundle/polymake.app/Contents/Resources/lib/libresources-4.0.2.dylib" "@rpath/libresources-4.0.2.dylib" Singular install_name_tool -change "/Users/andreas/polymake/polybundle/polymake.app/Contents/Resources/lib/libomalloc-0.9.6.dylib" "@rpath/libomalloc-0.9.6.dylib" Singular chmod u-w Singular cd
After that Singular should have the proper path references for the library it wants to load.

I currently have no working 10.10 enviroment around, but I will also build a new bundle and put it on our download page as soon as I have set up one.

Andreas


Return to “Installing polymake”

cron