Installing polymake on Xubuntu 14.04

Discussions on installation issues go here.

Moderator: Moderators

Christopher

Installing polymake on Xubuntu 14.04

Postby Christopher » 02 Dec 2014, 19:36

Hi,

I'm trying to install polymake on a MacBook running Xubuntu 14.04. When running "make" I get the following error message:

Code: Select all

In file included from /home/christopher/Schreibtisch/polymake-2.13-1/include/core-wrappers/polymake/SparseMatrix.h:20:0, from /home/christopher/Schreibtisch/polymake-2.13-1/apps/common/src/perl/SparseMatrix-7.cc:20: /home/christopher/Schreibtisch/polymake-2.13-1/include/core/polymake/SparseMatrix.h: In instantiation of ‘pm::SparseMatrix<E, _symmetric>::SparseMatrix(const pm::GenericMatrix<Matrix2, E>&, typename pm::enable_if<void**, ((! symmetric:: value) || pm::identical<symmetric, typename pm::matrix_symmetry_type<Matrix2>::type>::value)>::type) [with Matrix2 = pm::MatrixMinor<const pm::RowChain<pm::SingleRow<const pm::SameElementVector<const int&>&>, const pm::DiagMatrix<pm::SameElementVector<const int&>, true>&>&, const pm::Complement<pm::SingleElementSet<int>, int, pm::operations::cmp>&, const pm::all_selector&>; E = int; symmetric = pm::NonSymmetric; typename pm::enable_if<void**, ((! symmetric:: value) || pm::identical<symmetric, typename pm::matrix_symmetry_type<Matrix2>::type>::value)>::type = void**]’: /home/christopher/Schreibtisch/polymake-2.13-1/apps/common/src/perl/SparseMatrix-7.cc:36:7: required from ‘static sv* polymake::common::{anonymous}::Wrapper4perl_new_X<T0, T1>::call(sv**, char*) [with T0 = pm::SparseMatrix<int, pm::NonSymmetric>; T1 = pm::perl::Canned<const pm::MatrixMinor<const pm::RowChain<pm::SingleRow<const pm::SameElementVector<const int&>&>, const pm::DiagMatrix<pm::SameElementVector<const int&>, true>&>&, const pm::Complement<pm::SingleElementSet<int>, int, pm::operations::cmp>&, const pm::all_selector&> >]’ /home/christopher/Schreibtisch/polymake-2.13-1/include/core/polymake/perl/wrappers.h:170:21: required from ‘static void pm::perl::WrapperBase<Wrapper>::register_it(const char (&)[namelen], const char (&)[filelen], int, first_arg) [with long unsigned int namelen = 6ul; long unsigned int filelen = 86ul; first_arg = int; Wrapper = polymake::common::{anonymous}::Wrapper4perl_new_X<pm::SparseMatrix<int, pm::NonSymmetric>, pm::perl::Canned<const pm::MatrixMinor<const pm::RowChain<pm::SingleRow<const pm::SameElementVector<const int&>&>, const pm::DiagMatrix<pm::SameElementVector<const int&>, true>&>&, const pm::Complement<pm::SingleElementSet<int>, int, pm::operations::cmp>&, const pm::all_selector&> > >]’ /home/christopher/Schreibtisch/polymake-2.13-1/apps/common/src/perl/SparseMatrix-7.cc:34:4: required from ‘polymake::common::{anonymous}::Wrapper4perl_new_X<T0, T1>::Wrapper4perl_new_X(const char (&)[fl], int, first_arg_type) [with long unsigned int fl = 86ul; first_arg_type = int; T0 = pm::SparseMatrix<int, pm::NonSymmetric>; T1 = pm::perl::Canned<const pm::MatrixMinor<const pm::RowChain<pm::SingleRow<const pm::SameElementVector<const int&>&>, const pm::DiagMatrix<pm::SameElementVector<const int&>, true>&>&, const pm::Complement<pm::SingleElementSet<int>, int, pm::operations::cmp>&, const pm::all_selector&> >]’ /home/christopher/Schreibtisch/polymake-2.13-1/apps/common/src/perl/SparseMatrix-7.cc:53:4: required from here /home/christopher/Schreibtisch/polymake-2.13-1/include/core/polymake/SparseMatrix.h:691:4: internal compiler error: Speicherzugriffsfehler } ^ Please submit a full bug report, with preprocessed source if appropriate. See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions. The bug is not reproducible, so it is likely a hardware or OS problem. make[1]: *** [perl/SparseMatrix-7.o] Fehler 1 make[1]: Verlasse Verzeichnis '/home/christopher/Schreibtisch/polymake-2.13-1/build.x86_64/apps/common' make: *** [compile] Fehler 2
Thanks in advance,
Chris
Last edited by blorenz on 12 Dec 2014, 16:48, edited 1 time in total.
Reason: add code tags

User avatar
assarf
Developer
Posts: 74
Joined: 12 Oct 2011, 15:52

Re: Installing polymake on Xubuntu 14.04

Postby assarf » 06 Dec 2014, 14:10

Hi there,

could you please tell us the exact gcc version number? (via gcc -v).
You might want to try a different (newer) version of gcc.
no signature


Return to “Installing polymake”

cron