Ubuntu 14.04: crashing while configuring

Discussions on installation issues go here.

Moderator: Moderators

claudio vda
Posts: 4
Joined: 26 Oct 2014, 17:20

Ubuntu 14.04: crashing while configuring

Postby claudio vda » 26 Oct 2014, 17:46

Hello everybody. I tried to install polymake on an laptop with Ubuntu 14.04, but I am having troubles in the configuration.

First, I downloaded the package from here http://www.polymake.org/doku.php/downlo ... tributions (version 2.13 in tar.bz2) and then I followed the instructions from here http://www.polymake.org/doku.php/howto/install

As told in the instructions, I installed the long list of packages in the line for Ubuntu, then and also the one recomanded for Ubuntu 14.04, then I opened the tar.bz2 archive. In the archive I found a "configure" ssh: if I run it in a terminal, a terminal actually opens, but after a very short time it just crashes and gets closed.

Making a printscreen I was able to read what was written in the terminal: it seems there are some troubles with the bundled extensions, but every time the text is a little bit different and this is strange.

Here are 3 screenshots from 3 different attempts of configuring polymake

Image
Image
Image

I had a look on google about what libnormaliz is and I found that it is a C++ library for computations, but I didn't found a clar an univoque indication.

Sorry, do you have any clue about why I am in trouble running polymake?
And maybe... do you have any hints about the solution?

Thank-you very much in advance and sorry if my question is very basical.

User avatar
assarf
Developer
Posts: 74
Joined: 12 Oct 2011, 15:52
Contact:

Re: Ubuntu 14.04: crashing while configuring

Postby assarf » 27 Oct 2014, 09:50

Hello,

please correct me if I am wrong. But from the screenshots I suspect that you "double clicked" the configure file in your filebrowser (because I do not see any shell prompt). If that is the case the terminal did not "crash", it just closed itself after running the script.

What you might want to do is open a terminal, go to the directory where you unpacked polymake and run the command "./configure" (without the quotes). then you will probably see this after the command is finished:

Code: Select all

* Configuration successful. You should run 'make' now to build polymake. * If you have a multicore CPU use e.g. 'make -j2' to speed things up by using two parallel compile processes.
no signature

claudio vda
Posts: 4
Joined: 26 Oct 2014, 17:20

Re: Ubuntu 14.04: crashing while configuring

Postby claudio vda » 27 Oct 2014, 21:02

First of all, thanks for you answer :)

Actually you were right: I opened a terminal and I entered in the directory of polymake, then

Code: Select all

./configure
...and no problems at all!

Sorry for the little trouble.

User avatar
assarf
Developer
Posts: 74
Joined: 12 Oct 2011, 15:52
Contact:

Re: Ubuntu 14.04: crashing while configuring

Postby assarf » 28 Oct 2014, 08:59

glad I could help
no signature


Return to “Installing polymake”

cron