ERROR: Package "Polytope" does not exist

Discussions on installation issues go here.

Moderator: Moderators

jfine
Posts: 2
Joined: 14 Feb 2011, 08:33

ERROR: Package "Polytope" does not exist

Postby jfine » 14 Feb 2011, 08:41

I've upgraded from Ubuntu 9.4 (?) to 10.4 and polymake stopped working. So I downloaded and rebuilt from source. I'm now getting (for both 2.8 and 2.9):

$ cat temp.polymake.pl
new Polytope<Rational>;

$ polymake --version
polymake version 2.9.8, released on March 03, 2010
Copyright (c) 1997-2010
Ewgenij Gawrilow, Michael Joswig (TU Darmstadt)
http://www.polymake.de

$ polymake --script temp.polymake.pl
polymake: ERROR: "/path/to/file/temp.polymake.pl", line 1: Package "Polytope" does not exist


I'm now going to try 2.7.


Jonathan

jfine
Posts: 2
Joined: 14 Feb 2011, 08:33

Re: ERROR: Package "Polytope" does not exist

Postby jfine » 16 Feb 2011, 11:01

Version 2.7 works for me. So it's not urgent (for me) but it will make it hard for other to use my scripts, and so a proper fix would be good.

paffenholz
Developer
Posts: 182
Joined: 24 Dec 2010, 13:47

Re: ERROR: Package "Polytope" does not exist

Postby paffenholz » 16 Feb 2011, 11:20

polymakes needs to know about the application it should load to work with the script, so in your case you should start your file with

Code: Select all

use application 'polytope';
That should hopefully solve the issue.

Andreas

User avatar
gawrilow
Main Author
Posts: 354
Joined: 25 Dec 2010, 17:40

Re: ERROR: Package "Polytope" does not exist

Postby gawrilow » 16 Feb 2011, 16:36

You might also find useful the following in-depth scripting manual: http://www.polymake.org/doku.php/scripting/start.


Return to “Installing polymake”

cron