Documentation related "bugs"

Discussions on installation issues go here.

Moderator: Moderators

nkriha
Posts: 5
Joined: 26 Nov 2011, 21:59

Documentation related "bugs"

Postby nkriha » 26 Nov 2011, 22:46

I have no idea if this is the right place to post those things but I didn't find a better one.

"make docs" fails for me with the following error:

Code: Select all

/usr/bin/perl perl/polymake --script generate_docs /home/render/home/code/polymake210/share/polymake/doc common fan graph group matroid polytope topaz tropical polymake: ERROR: "/home/render/home/code/polymake-2.10/scripts/extract_docs", line 447: Can't call method "application" on an undefined value make: *** [docs] Error 1
http://polymake.mathematik.tu-darmstadt ... tions.html mentions "prevent_lazy" but I couldn't find it anywhere in the code base besides a doxygen related file.

The layout of all application related documentation sites at http://polymake.mathematik.tu-darmstadt ... cs/2.9.10/ and http://polymake.mathematik.tu-darmstadt ... ocs/2.9.9/ look broken.


The Prerequisites section of http://polymake.org/doku.php/tutorial/l ... s_tutorial seems to be out of date. Looks to me like the new polymake version does fine without any of those additional packages.

The help text for "save" has a little typo: "...has the true vakue."

herr
Developer
Posts: 41
Joined: 30 Dec 2010, 13:15

Re: Documentation related "bugs"

Postby herr » 30 Nov 2011, 13:03

You are right: "make docs" does not work for Release 2.10 due to some changes in the internal hierarchy. We already repaired it for the svn version. Hence, the feature will be available in the next release, which is scheduled for the end of this year. The links to the reference documentation for Release 2.9.10 and the svn version on the documentation page of the wiki should work, though. Please let us know if you still have problems with these links.

herr
Developer
Posts: 41
Joined: 30 Dec 2010, 13:15

Re: Documentation related "bugs"

Postby herr » 30 Nov 2011, 13:11

The help text for "save" has a little typo: "...has the true vakue."
Thanks for the hint. Now it's fixed. :)

blorenz
Developer
Posts: 109
Joined: 10 Jan 2011, 17:21

Re: Documentation related "bugs"

Postby blorenz » 30 Nov 2011, 15:34

The Prerequisites section of http://polymake.org/doku.php/tutorial/l ... s_tutorial seems to be out of date. Looks to me like the new polymake version does fine without any of those additional packages.
There are still several lattice properties that cannot be computed without external software:
HILBERT_BASIS, NORMAL, GROEBNER_BASIS, H_STAR_VECTOR and EHRHART_POLYNOMIAL. (Except maybe in some more or less trivial cases)
Only a client to compute the lattice points has been added since the tutorial has been written.

nkriha
Posts: 5
Joined: 26 Nov 2011, 21:59

Re: Documentation related "bugs"

Postby nkriha » 10 Jan 2012, 09:44

I found some more documentation related thingies.

unirand's documentation is missing the polytope parameter in the function signature and argument list.

on http://www.polymake.org/doku.php/general it says "prefer "*.convex_hull cdd lrs beneath_beyond";" but it should be "prefer "*.convex_hull cdd, lrs, beneath_beyond";

on http://polymake.org/doku.php/tutorial/l ... s_tutorial "polymake –reconfigure or polymake –reconfigure-rules" should be "polymake --reconfigure or polymake --reconfigure-rules"


Return to “Installing polymake”

cron