Perl version doesn't match on new installation for macOS Big Sur 11.6.2 (Intel processor)

Discussions on installation issues go here.
Casey
Posts: 3
Joined: 24 Jan 2022, 20:25

Perl version doesn't match on new installation for macOS Big Sur 11.6.2 (Intel processor)

Postby Casey » 24 Jan 2022, 20:38

Hello,
I am trying to install polymake on macOS Big Sur (Version 11.6.2, Intel Processor). I receive the following error after installing the polymake 4.5 MacOS 11.3 bundle. What is the best way to proceed to complete installation?

Code: Select all

your perl version (5.30.2) does not match the perl version this app was built for (5.18.4) please download and install the version of polymake that corresponds to the version of your system perl You can find the version number by executing /usr/bin/perl --version in a terminal. If there is no version of the polymake app matching your perl version please contact us at http://forum.polymake.org
Thank you very much!

paffenholz
Developer
Posts: 203
Joined: 24 Dec 2010, 13:47

Re: Perl version doesn't match on new installation for macOS Big Sur 11.6.2 (Intel processor)

Postby paffenholz » 24 Jan 2022, 23:04

Sorry, I linked the wrong package. Copy&paste.

Andreas

Casey
Posts: 3
Joined: 24 Jan 2022, 20:25

Re: Perl version doesn't match on new installation for macOS Big Sur 11.6.2 (Intel processor)

Postby Casey » 25 Jan 2022, 04:31

Hi Andreas,

Thank you! I uninstalled the initial installation (by dragging it to trash) and reinstalled the new bundle you have linked. I now receive a new error:

Code: Select all

casey@Caseys-MBP ~ % /Applications/polymake.app/Contents/MacOS/polymake.run ; exit; grep: /Applications/polymake.app/Contents/Resources/polymake/lib/polymake/config.ninja: No such file or directory polymake build configure file is missing This should not happen. Your bundle seems to be corrupt. Please reinstall. Saving session... ...copying shared history... ...saving history...truncating history files... ...completed. [Process completed]
Advice appreciated, and thank you.
Casey

paffenholz
Developer
Posts: 203
Joined: 24 Dec 2010, 13:47

Re: Perl version doesn't match on new installation for macOS Big Sur 11.6.2 (Intel processor)

Postby paffenholz » 27 Jan 2022, 14:48

Indeed, this bundle is broken. I am sorry.

I was preparing bundles for the new version of polymake anyway, so I thought I provide this instead, but this currently does not work for Mac OS 11 (Big Sur). I have to investigate the reason and will publish the bundle once I found and fixed the problem.

The binaries for homebrew, however, are done and working for polymake 4.6. Maybe you could install via homebrew instead?

paffenholz
Developer
Posts: 203
Joined: 24 Dec 2010, 13:47

Re: Perl version doesn't match on new installation for macOS Big Sur 11.6.2 (Intel processor)

Postby paffenholz » 29 Jan 2022, 15:59

The bundle should be fixed now and contain the latest version 4.6

Andreas

Casey
Posts: 3
Joined: 24 Jan 2022, 20:25

Re: Perl version doesn't match on new installation for macOS Big Sur 11.6.2 (Intel processor)

Postby Casey » 04 Feb 2022, 01:06

Dear Andreas,
Thank you very much! I installed polymake 4.6 via home-brew and am very excited about the new graphics features in the new version. They are quite nice and make for some beautiful images! Thank you for these improvements, and for your help with the installation.
Casey Pinckney


Return to “Installing polymake”