mptopcom1.0 fails to build

Discussions on installation issues go here.

Moderator: Moderators

beew
Posts: 25
Joined: 13 Aug 2015, 20:41

mptopcom1.0 fails to build

Postby beew » 02 Mar 2019, 22:12

Not sure if it belongs here, if not my apologies. After successfully configuring mptopcom 1.0, ninja -C build/Opt -j8
results in errors

Code: Select all

ninja: Entering directory `build/Opt' [1/1] GENERATE /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/targets.ninja [1/117] COMPILE /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/Opt/lib-src/ComputeTriangs.o FAILED: /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/Opt/lib-src/ComputeTriangs.o g++ -DPACKAGE_NAME=\"TOPCOM\" -DPACKAGE_TARNAME=\"topcom\" -DPACKAGE_VERSION=\"0.17.8\" -DPACKAGE_STRING=\"TOPCOM\ 0.17.8\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"topcom\" -DVERSION=\"0.17.8\" -DGMPRATIONAL -c -o /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/Opt/lib-src/ComputeTriangs.o -MMD -MT /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/Opt/lib-src/ComputeTriangs.o -MF /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/Opt/lib-src/ComputeTriangs.o.d -fPIC -pipe -std=c++14 -march=native -ftemplate-depth-200 -fno-strict-aliasing -Wno-parentheses -fwrapv -fopenmp -DNDEBUG -O3 -I/usr/local/include -I/home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src -I/home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-reg -I/home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/wrap-gmp-gmpxx -I/home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-ReverseSearch -DPOLYMAKE_VERSION=303 -fPIC -pipe -std=c++14 -march=native -ftemplate-depth-200 -fno-strict-aliasing -Wno-parentheses -Wshadow -fopenmp -Wno-error=unused-function -O3 -DPOLYMAKE_DEBUG=0 -I/usr/local/include -I/usr/local/include/polymake/external /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src/ComputeTriangs.cc In file included from /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-ReverseSearch/SymmetryBlackBox.hh:33:0, from /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-ReverseSearch/FlipData.hh:39, from /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-ReverseSearch/PrimitiveFlipCache.hh:39, from /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-ReverseSearch/ReverseSearch.hh:43, from /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src/ComputeTriangs.cc:32: /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-ReverseSearch/GroupDecomposer.hh:37:29: fatal error: polymake/Series.h: No such file or directory compilation terminated. [5/117] COMPILE /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/Opt/lib-src-reg/RegularityCheck.o /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-reg/RegularityCheck.cc: In constructor ‘RegularityCheck::RegularityCheck(const PointConfiguration&, const Chirotope&, const SimplicialComplex&)’: /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-reg/RegularityCheck.cc:64:18: warning: declaration of ‘basis_matrix’ shadows a previous local [-Wshadow] StairCaseMatrix basis_matrix; ^ /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/lib-src-reg/RegularityCheck.cc:42:23: note: shadowed declaration is here StairCaseMatrix basis_matrix; ^ [8/117] COMPILE /home/bernard/Downloads/assorted_math_packages/mptopcom-1.0/build/Opt/src/santos_triang.o ninja: build stopped: subcommand failed
polymake3.3 on Ubuntu16.04.6

lkastner
Developer
Posts: 8
Joined: 27 May 2012, 23:35

Re: mptopcom1.0 fails to build

Postby lkastner » 04 Mar 2019, 11:07

Thank you for the bug report, this is the right place. I just uploaded a new revision at https://polymake.org/lib/exe/fetch.php/ ... r2.tar.bz2. I checked it with polymake 3.3, so hopefully this also works for you. It will still produce some warnings during build, these will be gone in the next mptopcom release.

beew
Posts: 25
Joined: 13 Aug 2015, 20:41

Re: mptopcom1.0 fails to build

Postby beew » 05 Mar 2019, 01:08

Works now. Thanks!


Return to “Installing polymake”

cron