Perl version doesn't match after Mac 11.3 update (Intel chip)

Discussions on installation issues go here.
tidues
Posts: 1
Joined: 29 Apr 2021, 15:49

Perl version doesn't match after Mac 11.3 update (Intel chip)

Postby tidues » 29 Apr 2021, 15:54

After the recent update, I got this:
==========================================================================
your perl version (5.30.2) does not match the perl version this
app was built for (5.28.2)
please download and install the version of polymake that corresponds
to the version of your system perl
You can find the version number by executing
/usr/bin/perl --version
in a terminal.
If there is no version of the polymake app matching your perl version
please contact us at http://forum.polymake.org
==========================================================================
Any suggestion? Thanks!

Valentin
Posts: 1
Joined: 14 May 2021, 16:48

Re: Perl version doesn't match after Mac 11.3 update (Intel chip)

Postby Valentin » 14 May 2021, 17:01

I guess this always happens whenever Apple decides to update our system perl. According to this post viewtopic.php?t=1713 you can either wait until one of the Devs will upload a new precompiled version or compile polymake yourself.
I did the latter and now polymake works again but I get a warning at startup "Warning: some rulefiles could not be configured automatically due to lacking third-party software and/or other issues.".

Best
Valentin

User avatar
gawrilow
Main Author
Posts: 385
Joined: 25 Dec 2010, 17:40

Re: Perl version doesn't match after Mac 11.3 update (Intel chip)

Postby gawrilow » 19 May 2021, 23:37

If you execute

Code: Select all

show_unconfigured;
in the polymake shell, it will tell you what exactly is missing. Most probably, you got this message also before the perl upgrade, because interfaces to third-party software usually do not depend on exact perl version.

paffenholz
Developer
Posts: 195
Joined: 24 Dec 2010, 13:47

Re: Perl version doesn't match after Mac 11.3 update (Intel chip)

Postby paffenholz » 21 May 2021, 22:03

Many thanks for pointing out the change in the perl version. This always comes unexpected... I have uploaded a new bundle for 11.3, and with the brand new polymake version 4.4.

Andreas


Return to “Installing polymake”

cron