Search found 99 matches

Go to advanced search

by blorenz
02 Nov 2021, 09:30
Forum: Installing polymake
Topic: Perl MongoDB module at EOL
Replies: 1
Views: 134

Re: Perl MongoDB module at EOL

Hello,

we do have plans about that but unfortunately none of that is implemented yet. We will probably switch to the MongoDB C++ driver.
In addition to that we might try to add a very basic interface that doesn't need any extra libraries but interfaces directly with our Rest API.

Best
Benjamin
by blorenz
07 Sep 2021, 11:44
Forum: Installing polymake
Topic: SageMath installation problems
Replies: 2
Views: 3992

Re: SageMath installation problems

Dear Simon, I can only tell you as much as that this error message is not from the polymake build-system. Since the polymake team is not involved in the SageMath interface we cannot help you any further, so please try asking in the SageMath forum or have a look at these question with a similar error...
by blorenz
28 Aug 2021, 19:27
Forum: Installing polymake
Topic: Testsuite regression with nauty on FreeBSD
Replies: 2
Views: 2475

Re: Testsuite regression with nauty on FreeBSD

Unfortunately there is a small mistake in the patch, in the case that --without-prereq is passed to configure the -lnauty flag for the linker will be missing. Please try this patch: https://polymake.org/downloads/libnauty2.patch

Benjamin
by blorenz
14 Aug 2021, 10:00
Forum: General Discussion
Topic: Mixed volume -> edge matrix is singular?
Replies: 4
Views: 4923

Re: Mixed volume -> edge matrix is singular?

Hi, unfortunately you hit a bug in our mixed volume implementation. This bug is already fixed in the most recent polymake release 4.4, but is still present in the 4.2 release that was active in the webpolymake until today. I have now updated webpolymake to version 4.4 which does work for your exampl...
by blorenz
25 Jun 2021, 13:26
Forum: Installing polymake
Topic: polymake on FreeBSD -- some questions and help needed
Replies: 10
Views: 4826

Re: polymake on FreeBSD -- some questions and help needed

I have another question concerning the shared library: Right now, the port provides libpolymake.so.4.4 and libpolymake-apps-rt.so.4.4. What about libpolymake-apps.so.4.4? Should that one be provided, too? If so, I have to figure out why that one is not picked up by pkg. Sorry for the delay. That li...
by blorenz
18 Jun 2021, 23:34
Forum: Installing polymake
Topic: polymake on FreeBSD -- some questions and help needed
Replies: 10
Views: 4826

Re: polymake on FreeBSD -- some questions and help needed

I don't really know how you ended up with these undefined symbol errors for libnormaliz but they should disappear when adding ' -lnauty ' in the correct place, either in the global ' LIBS ' variable passed to configure ( ./configure LIBS=-lnauty ) or by adding an appropriate check in the libnormaliz...
by blorenz
18 Jun 2021, 09:42
Forum: Installing polymake
Topic: polymake on FreeBSD -- some questions and help needed
Replies: 10
Views: 4826

Re: polymake on FreeBSD -- some questions and help needed

Hi, I am currently working on bringing polymake into the FreeBSD ports system. It builds fine and the testsuite runs without errors. I am working with the polymake-4.4-minimal version. Thanks a lot for working on this and that is already a very good starting point. Because of problems with the respe...
by blorenz
17 Jun 2021, 12:47
Forum: Helpdesk
Topic: Stable intersection not contained in set-theoretic intersection
Replies: 6
Views: 3724

Re: Stable intersection not contained in set-theoretic intersection

Thanks for looking into this Simon! We will try to take care of this next week.
by blorenz
14 Apr 2021, 13:51
Forum: Helpdesk
Topic: Segmentation fault when using Polymake in Julia
Replies: 8
Views: 4406

Re: Segmentation fault when using Polymake in Julia

For updating the packages can you try running using Pkg; Pkg.update(); (Latest versions are Polymake.jl 0.5.5 and Oscar.jl 0.5.1.) For lldb, and also to test this in a clean environment it would be good to try this directly in the julia shell. So please run Base.julia_cmd() in your REPL. This should...
by blorenz
14 Apr 2021, 10:17
Forum: Helpdesk
Topic: Segmentation fault when using Polymake in Julia
Replies: 8
Views: 4406

Re: Segmentation fault when using Polymake in Julia

Hi, it is rather hard to say what can be causing this, I have seen a similar error once or twice on our MacOS CI but it was not really reproducible. Can you please provide some more details on your configuration, i.e. versioninfo(); using Pkg; Pkg.status(); You can also try updating your packages (a...

Go to advanced search

cron