Search found 145 matches

Go to advanced search

by paffenholz
05 Nov 2021, 14:11
Forum: General Discussion
Topic: Finding integer vertices in an MILP
Replies: 4
Views: 200

Re: Finding integer vertices in an MILP

I am not sure what you mean by "extreme point". Can you please give a definition? There are eight integral points contained in the polytope, which you can compute via print $p->LATTICE_POINTS; 1 0 0 1 0 1 1 1 0 1 1 1 1 2 0 1 2 1 1 3 0 1 4 0 Six of them are on the boundary: print $p->BOUNDARY_LATTICE...
by paffenholz
03 Nov 2021, 15:22
Forum: General Discussion
Topic: Finding integer vertices in an MILP
Replies: 4
Views: 200

Re: Finding integer vertices in an MILP

Yor can compute the integer hull of a polyhedron with the function integer_hull and then ask for the vertices: $q=integer_hull($p); print $q->VERTICES; 1 0 0 1 0 1 1 2 1 1 4 0 Note however, that this internally computes a representation of all integer points in the polyhedron. There is no significan...
by paffenholz
21 May 2021, 22:03
Forum: Installing polymake
Topic: Perl version doesn't match after Mac 11.3 update (Intel chip)
Replies: 3
Views: 3372

Re: Perl version doesn't match after Mac 11.3 update (Intel chip)

Many thanks for pointing out the change in the perl version. This always comes unexpected... I have uploaded a new bundle for 11.3, and with the brand new polymake version 4.4.

Andreas
by paffenholz
26 Mar 2021, 09:26
Forum: Helpdesk
Topic: macOS Installation Problems
Replies: 4
Views: 3604

Re: macOS Installation Problems

The missing EXTERN.h should hopefully be found after

Code: Select all

export CPATH=/Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/System/Library/Perl/5.18/darwin-thread-multi-2level/CORE/
before installing with

Code: Select all

cpanm Term::ReadLine::Gnu
Andreas
by paffenholz
24 Mar 2021, 09:49
Forum: Helpdesk
Topic: macOS Installation Problems
Replies: 4
Views: 3604

Re: macOS Installation Problems

On 10.15 and later it is not anymore necessary to force link the readline library. I have updated the installation instructions. But the installation of Term::ReadLine::Gnu should have worked regardless. Can you retry to install it with cpanm Term::ReadLine::Gnu and if it fails post the error message?
by paffenholz
15 Mar 2021, 00:39
Forum: Installing polymake
Topic: Can't locate loadable object for module Polymake::Ext in @INC
Replies: 4
Views: 3399

Re: Can't locate loadable object for module Polymake::Ext in @INC

Yes, sorry, remains of the previous installation of polymake were not the only problem. I was able to reproduce this on my VM. The perl bottle of brew has been updated from 5.32.0 to 5.32.1 since I compiled the bottles. As polymake uses perl XS, which is compiled code and depends on the precise vers...
by paffenholz
12 Mar 2021, 18:14
Forum: Installing polymake
Topic: Can't locate loadable object for module Polymake::Ext in @INC
Replies: 4
Views: 3399

Re: Can't locate loadable object for module Polymake::Ext in @INC

I assume that your previous version of polymake was not installed with 'brew install polymake' but either completely self compiled or using brew just for the dependencies, and then polymake was installed into the standard location with 'ninja -C build/Opt install'? In that case you probably have a v...
by paffenholz
02 Mar 2021, 22:24
Forum: Helpdesk
Topic: Error in reading a .lp file using lp2poly
Replies: 6
Views: 4562

Re: Error in reading a .lp file using lp2poly

Your file is utf-8 encoded, while polymake expects a file that only contains the standard ascii characters. As long as you stick to letters/digits/spaces this is not a problem. But utf-8 has several versions of a space character, and your file contains some of the "nonstandard" spaces. You can see t...
by paffenholz
14 Jan 2021, 18:17
Forum: Installing polymake
Topic: installing polymake 4.3 on Mac OS X 11.1, Big Sur
Replies: 5
Views: 3689

Re: installing polymake 4.3 on Mac OS X 11.1, Big Sur

SVG is indeed missing in the latest bottle, and I also remember now that I had a reason to remove the module some time ago (it did not compile properly). However, SVG is not a necessary prerequesite for polymake, so it should work without. I assume you still have an old local polymake configuration ...
by paffenholz
14 Jan 2021, 17:37
Forum: Installing polymake
Topic: installing polymake 4.3 on Mac OS X 11.1, Big Sur
Replies: 5
Views: 3689

Re: installing polymake 4.3 on Mac OS X 11.1, Big Sur

This looks like a polymake installed via Homebrew? So you issued brew install polymake at most two days ago (I only updated the formula on tuesday to hopefully also work for Big Sur, seems it still does not). By design of homebrew all perl modules used by polymake are bundled together with the polym...

Go to advanced search

cron