Search found 132 matches

Go to advanced search

by paffenholz
03 Sep 2019, 13:19
Forum: Helpdesk
Topic: Content of Cone::RAYS if there are no extreme rays
Replies: 4
Views: 1166

Re: Content of Cone::RAYS if there are no extreme rays

I am not sure I understand what you intend to do. Without own programming polymake does not do any incremental generation of extreme rays or generators (some convex hull codes used by polymakemay do this internally, but we don't provide access to this). You however get the following guarantee: If yo...
by paffenholz
26 Aug 2019, 23:25
Forum: Helpdesk
Topic: Content of Cone::RAYS if there are no extreme rays
Replies: 4
Views: 1166

Re: Content of Cone::RAYS if there are no extreme rays

polymake splits the information about the generating set of a cone C into two parts: For any cone we can find a pointed cone D and a linear space L such that C is the Minkowski sum of those two (Minkowski-Weyl-Theorem). The cone D has a unique (up to scaling of the individual generators by a positiv...
by paffenholz
19 Jul 2019, 23:50
Forum: Installing polymake
Topic: Installing the Julia-package on macOS 10.14.5
Replies: 7
Views: 696

Re: Installing the Julia-package on macOS 10.14.5

One more thing: polymake sometimes compiles new code at runtime and rebuilds some libraries (whenever you, or a package you use, uses a C++-template instance of a polymake class that did not occur before). So you should set the variables each time you use polymake in julia, or wrap the julia call in...
by paffenholz
19 Jul 2019, 23:46
Forum: Installing polymake
Topic: Installing the Julia-package on macOS 10.14.5
Replies: 7
Views: 696

Re: Installing the Julia-package on macOS 10.14.5

Congratulations. Enjoy!

Thanks for the notice and for reporting the solution. As polymake has found gmp and mpfr I would suspect that the include paths and linker flags somehow get lost in the Julia package installation. We will check this.

Andreas
by paffenholz
19 Jul 2019, 22:12
Forum: Installing polymake
Topic: Installing the Julia-package on macOS 10.14.5
Replies: 7
Views: 696

Re: Installing the Julia-package on macOS 10.14.5

No, you don't need any of the packages that failed during the configure step. All java stuff doesn't work properly on mac os anyway. Scip ist for optimization, bliss is a replacement for nauty, singular is for computations with ideals. The output of polymake-config looks good. With my question for a...
by paffenholz
19 Jul 2019, 17:37
Forum: Installing polymake
Topic: Installing the Julia-package on macOS 10.14.5
Replies: 7
Views: 696

Re: Installing the Julia-package on macOS 10.14.5

Unfortunately I cannot reproduce your problem on a fresh installation of 10.14. I would need some more details of your installation process. - Did you install brew into the standard location (which is /usr/local), or to some other path? - Does the file /usr/local/include/gmp.h exist? - Have you prov...
by paffenholz
03 Jun 2019, 22:57
Forum: Helpdesk
Topic: Calling polymake from another program on a mac
Replies: 5
Views: 452

Re: Calling polymake from another program on a mac

polymake works the same way on Mac and Linux. The only thing that might make it look different is the binary version bundled as a Mac application. This is due to the way Apple has organized its applications. I can't change this. But apart from following apple's folder and file name requirements, the...
by paffenholz
01 Jun 2019, 10:58
Forum: Installing polymake
Topic: Installing from source on macOS 10.13
Replies: 4
Views: 450

Re: Installing from source on macOS 10.13

Seems we tested but did not properly update the instructions. Can you try the configure without any of the options you used, so just

Code: Select all

./configure
Andreas
by paffenholz
21 May 2019, 15:43
Forum: Installing polymake
Topic: Downgrading perl in MacOs
Replies: 2
Views: 388

Re: Downgrading perl in MacOs

I was not aware of this perl update in 10.14.5 and I don't see it documented somewhere. Nice. Until now 5.18.2 was the only system perl available on 10.11 to 10.14, so this was stable for around two years now. And considering that by now there is perl 5.28 available, going from 5.18.2 to 5.18.4 is a...
by paffenholz
10 Apr 2019, 21:27
Forum: Installing polymake
Topic: Compiling polymake on macOS 10.14
Replies: 6
Views: 930

Re: Compiling polymake on macOS 10.14

Your java is alright. The compilation fails as the version of the software jreality that comes with polymake requires a java version that is older than the last version supported by java 12. On MacOS jreality currently doesn't work properly anyway. I suggest to switch this off entirely during compil...

Go to advanced search

cron