Search found 35 matches

Go to advanced search

by jamesjer
07 Nov 2023, 16:16
Forum: Installing polymake
Topic: Undefined behavior in topaz app
Replies: 2
Views: 10524

Undefined behavior in topaz app

The Fedora project builds packages with -D_GLIBCXX_ASSERTIONS. One of the assertions failed while running the polymake 4.11 test suite. In apps/topaz/src/barycentric_subdivision.cc, line 142, description.back() is called. However, during test suite execution at least, description can be empty. Calli...
by jamesjer
06 Nov 2023, 19:27
Forum: Installing polymake
Topic: perl 5.38.0
Replies: 16
Views: 27889

Re: perl 5.38.0

I want to thank you for releasing polymake 4.11. That is a much needed lifeline to help us distribution packagers keep things going for a little while longer. I wish you good speed on the Julia version.
by jamesjer
03 Oct 2023, 17:45
Forum: Installing polymake
Topic: perl 5.38.0
Replies: 16
Views: 27889

Re: perl 5.38.0

Presumably the perl maintainers want to make some changes to the internals. As for temporary measures, let me point out the incomplete patch for perl 5.38 mentioned above: https://jjames.fedorapeople.org/polymake-perl-5.38.patch. That patch lets polymake compile, and "polymake --reconfigure&quo...
by jamesjer
02 Aug 2023, 19:06
Forum: Installing polymake
Topic: perl 5.38.0
Replies: 16
Views: 27889

Re: perl 5.38.0

I understand. I look forward to seeing your Julia work.
by jamesjer
27 Jul 2023, 04:13
Forum: Installing polymake
Topic: perl 5.38.0
Replies: 16
Views: 27889

Re: perl 5.38.0

I announced my intention to retire the polymake package on the Fedora developers list. Kevin Kofler remarked that pointers to Perl_ck_fun can be found in PL_check array, and that the body of Perl_save_pushptrptr can be copied verbatim into the polymake code. That got me wondering how many more such ...
by jamesjer
18 Jul 2023, 00:00
Forum: Installing polymake
Topic: perl 5.38.0
Replies: 16
Views: 27889

Re: perl 5.38.0

Sadly, the approach of keeping perl 5.36 around is not really feasible. It might be technically feasible, but the amount of time and attention it would require is far more than I can take on. I think I will have to withdraw polymake from Fedora for now. I wish you good luck and good speed in moving ...
by jamesjer
14 Jul 2023, 17:48
Forum: Installing polymake
Topic: perl 5.38.0
Replies: 16
Views: 27889

perl 5.38.0

The Fedora Linux distribution just updated to perl 5.38.0 in Rawhide, which will become Fedora 39 in the fall. Since polymake 4.10 is incompatible with perl 5.38.0, this leaves the polymake package unbuildable and uninstallable. As the polymake package maintainer, I need to decide what to do. As I s...
by jamesjer
10 Mar 2020, 16:05
Forum: Helpdesk
Topic: Porting old code
Replies: 3
Views: 8888

Re: Porting old code

Thank you for the update to the legacy page. It was very helpful. I still had to do some work, but I can now tell you that polymake 4.0r1 will be in Fedora 32 and that, so far as I am able to tell, all consuming packages work correctly. There is a newer interface from GAP, namely https://homalg-proj...
by jamesjer
24 Feb 2020, 01:21
Forum: Helpdesk
Topic: Porting old code
Replies: 3
Views: 8888

Porting old code

Thank you for the 4.0 and 4.0r1 releases! I am looking at building 4.0r1 for Fedora, but will need to port some of the GAP packages (primarily https://github.com/gap-packages/polymaking ) first. While looking through your web pages for documentation to help me do this, I found https://polymake.org/d...
by jamesjer
19 Jan 2017, 17:59
Forum: Installing polymake
Topic: Purpose of libpolymake-apps
Replies: 2
Views: 8441

Re: Purpose of libpolymake-apps

Thank you for the explanation. That helped a lot. Polymake does not currently violate any Fedora packaging guidelines. The question arises in the context of some work on attempting to optimize ldconfig invocations during package installation. Would it work as well to mark all application symbols as ...

Go to advanced search